!NSECLCROhIvzhDnRnu:matrix.org

I2P [ UNOFFICIAL ]

264 Members
DO NOT ASK FOR OR ADVERTISE ILLEGAL SERVICES OR MARKETS28 Servers

Load older messages


SenderMessageTime
20 Feb 2024
@berry:berryez.xyzMr.Macska
In reply to @rosa08:matrix.org
so i need to let it through my modem
Yes
08:49:35
@berry:berryez.xyzMr.MacskaYou need to open it in your router. For me i have port 5903 set in my i2pd config and opened on my router and my status is OK08:50:11
@berry:berryez.xyzMr.Macska
In reply to @rosa08:matrix.org
i just dont know how i can get the i2p to forward it through the router
So basically if you create a tunnel in i2pd your router will forward all its traffic via your routers port (for me 5903)
08:51:41
@berry:berryez.xyzMr.MacskaSo you only need to open one port for all of your tunnels08:51:52
@rails11326206827:matrix.orgTremorIts not rewuired to port forward for i2p to work. It helps you reach more peers though. Just an FYI.23:58:02
21 Feb 2024
@rails11326206827:matrix.orgTremor* Its not required to port forward for i2p to work. It helps you reach more peers though. Just an FYI.00:01:27
@rosa08:matrix.orgrosa08
In reply to@berry:berryez.xyz
You need to open it in your router. For me i have port 5903 set in my i2pd config and opened on my router and my status is OK
oh ok
00:42:54
@rosa08:matrix.orgrosa08so how do i specify this in i2pd config sorry?00:43:03
@rails11326206827:matrix.orgTremor
In reply to @rosa08:matrix.org
so how do i specify this in i2pd config sorry?
https://i2pd.readthedocs.io/en/latest/user-guide/configuration/
00:57:43
@rails11326206827:matrix.orgTremor

Top level of the .conf file. Meaning not under and [section] parts.

port = 9999

00:58:17
@rosa08:matrix.orgrosa08ok i changed it to port = 5500 (port im forwarding from virtualbox)01:26:48
@rosa08:matrix.orgrosa08but its still saying firewalled01:26:52
@rosa08:matrix.orgrosa08when i curl localhost:7070 and search it says Firewalled - Symmetric NAT01:27:34
@rosa08:matrix.orgrosa08Screenshot from 2024-02-21 12-29-53.png
Download Screenshot from 2024-02-21 12-29-53.png
01:30:16
@rosa08:matrix.orgrosa08this is the router cofnig also if it helps01:30:23
@rosa08:matrix.orgrosa08i've confirmed static ip is working01:30:28
@rosa08:matrix.orgrosa08
In reply to@rosa08:matrix.org
Screenshot from 2024-02-20 18-45-47.png
and vbox config as above
01:30:49
@rails11326206827:matrix.orgTremor"Run peer test" to test01:31:08
@rosa08:matrix.orgrosa08can i do that from cli by any chance?01:31:34
@rosa08:matrix.orgrosa08(running debian i2pd)01:32:09
@rails11326206827:matrix.orgTremorHonestly not sure. I use the web interface01:40:58
@rosa08:matrix.orgrosa08ah it is potentially a problem with port forwarding actually01:43:56
@rosa08:matrix.orgrosa08thanks for the help ill report back01:44:00
@rails11326206827:matrix.orgTremorI2pd host OS is Debian? Are you using iptables or ufw or something else?01:46:40
@rosa08:matrix.orgrosa08no firewall at all, this is just a test run i'll be setting up the actual server somewhere else and not a vm01:47:33
@rails11326206827:matrix.orgTremorSo everything is reachable on that then?01:50:31
@rails11326206827:matrix.orgTremorI guess the next question is do you have a public IP address to work with?01:53:13
@rosa08:matrix.orgrosa08i think i found out the problem02:07:32
@rosa08:matrix.orgrosa08we got a new router and it seems to be doing a double nat thing02:07:45
@rosa08:matrix.orgrosa08i think i can fix it by changing it to access point mode02:08:00

Show newer messages


Back to Room ListRoom Version: 6