!cApDlsILLZkmAyVoxe:matrix.org

Matrix on Debian

204 Members
https://wiki.debian.org/Matrix75 Servers

Load older messages


SenderMessageTime
27 Aug 2018
@ptman:matrix.orgPaulautomatic restarting might be a bit heavy-handed14:25:42
@joerg:alea.gnuu.deJΓΆrg SommerBut it's common for package updates and it's necessary to bring the new code in action. Otherwise the bugs stay online and the user questions why the new version doesn't work.15:07:06
28 Aug 2018
@richvdh:sw1v.orgrichvdh https://github.com/matrix-org/package-synapse-debian/issues/18 06:27:24
5 Sep 2018
@richvdh:sw1v.orgrichvdh andrewsh: btw, nothing to do with the security drama, but we realised that twisted 18.4 needs pyopenssl 16.0 or later 13:38:36
@richvdh:sw1v.orgrichvdh(of which there are existing backports packages)13:38:48
@richvdh:sw1v.orgrichvdhbut we should probably update the Twisted 18.4 packages13:39:06
@andrewsh:matrix.organdrewshoh, okay πŸ™‚13:39:13
@andrewsh:matrix.organdrewshwait13:39:25
@andrewsh:matrix.organdrewshit's already 16.2.0-1 in stable13:39:35
@richvdh:sw1v.orgrichvdhright, it is, but it turns out that if you think you will just lift the twisted package and install it on some system that doesn't have 16.2, it all works just fine up to the point that your ssl fails mysteriously13:41:08
@richvdh:sw1v.orgrichvdhI don't know if that's a real problem that debian packages tend to care about - I can imagine it maybe causing problems when upgrading13:42:41
@andrewsh:matrix.organdrewshhttps://salsa.debian.org/python-team/modules/twisted/commits/stretch-backports13:52:55
@andrewsh:matrix.organdrewshfeel free to build that and ship in your repo13:53:07
@richvdh:sw1v.orgrichvdhyou are a star13:54:15
@richvdh:sw1v.orgrichvdhthank you sir13:54:16
@andrewsh:matrix.organdrewshI will upload that as soon as twisted gets into backports13:54:40
@andrewsh:matrix.organdrewsh(it's still in the BACKPORTS-NEW queue)13:54:54
8 Sep 2018
@gitgud:banter.citygitgud left the room.04:36:28
14 Sep 2018
@andrewsh:matrix.organdrewsh changed their profile picture.17:00:16
16 Sep 2018
@shirish:matrix.orgshirishI am open to testing anything if needed in experimental or whatever just to see if I can be of help. 13:41:24
17 Sep 2018
@uhoreg:matrix.orguhoreg matrix-js-sdk finally made it into Debian unstable. Now I need to update it to a more recent version 16:38:08
18 Sep 2018
@MilkManzJourDaddy:matrix.orgMilkManzJourDaddy [99-Problems/AπŸ“ŒπŸš/Falayalaralfali] πŸ’₯πŸ”¨ Castigare troglodytam. Malleo pugnae aviditate. πŸŒŠπŸ‘‹πŸ™‹\o πŸ’₯πŸ”¨ ZFG πŸ™Œ ℒ¦¢␍ β†΅β€β†˜β†¦: changed their display name from MilkManzJourDaddy [99-Problems/AπŸ“ŒπŸš/Falayalaralfali] to MilkManzJourDaddy [99-Problems/AπŸ“ŒπŸš/Falayalaralfali] Z.Fs.G.!.23:30:57
19 Sep 2018
@shirish:matrix.orgshirishcould somebody do a NMU of nheko (maybe a more recentish version) till the maintainer doesn't come back from his holidays 10:41:51
@shirish:matrix.orgshirishsee #908101 . I tried to build a local build but saw there are lot of dependant packages which is not in Debian, chiefly mtxclient at this point which requires synapse :(10:44:25
@shirish:matrix.orgshirishmy bad, syanpse is there, the boost library is old hence can't build tmxclient . I know a boost transition is in works but when is not known. 10:56:50
@uhoreg:matrix.orguhoregI'm back from vacation, and I already started looking at updating nheko, but it's non-trivial, as you have found. But in general, it is not appropriate to ask for an NMU when the maintainer has already said that they would look into it.12:47:13
@joerg:alea.gnuu.deJΓΆrg SommerACK12:48:01
@shirish:matrix.orgshirishuhoreg, apologies. yup, saw it's non-trivial to build. It basically needs the newer boost libraries, there are discussions on the new boost-defaults where perhaps matrix people could also weigh in, #90431614:40:33
23 Sep 2018
@dsn-traveller:dsn-traveller.dsn.scc.kit.eduDSN Traveller (bot) left the room.18:27:02
19 Sep 2018
@uhoreg:matrix.orguhoregThat doesn't really seem like a discussion that I would have much to add to, as none of my packages need to transition. But I'm planning on just doing a "libboost-dev (>= 1.66) | libboost1.67-dev" to work around that for now.14:47:31

Show newer messages


Back to Room ListRoom Version: