!JlyDNoJGELxCfReXhe:matrix.org

Dev-help

12 Members
Aragon development troubleshooting and help-related discussions1 Servers

Load older messages


Timestamp Message
17 Sep 2019
19:09:29@bridge-bot:matrix.orgbridge-bot <emily>thrown from here:

window.aragonClient.rpc.provider.messages().subscribe(payload => {
  logDebug('Aragon client message: ', payload)
  if (payload && payload.error) {
    throw new Error(`Aragon client error: ${payload.error}`)
  }
})
19:13:52@bridge-bot:matrix.orgbridge-bot <emily>where
window.aragonClient = new Aragon(new providers.WindowMessage(window.parent))
20:06:27@bridge-bot:matrix.orgbridge-bot <emily>also the reason I’m trying to update the API is because the current version is telling me my function name doesn’t exist even though it’s right in my abi. (it’s been intermittent…I may have tinkered with my contract in my node modules folder or somehting and it was working for a while, but it’s happening again)
20:38:32@bridge-bot:matrix.orgbridge-bot <mcormier>Hey @emily I don’t know about the cache problem but is your setResult function inherited from another contract?
20:38:56@bridge-bot:matrix.orgbridge-bot <mcormier>If so, I think aragon doesn’t support calling inherited functions from the frontend yet
20:39:08@bridge-bot:matrix.orgbridge-bot <mcormier>https://github.com/aragon/aragon-cli/issues/133
20:39:59@bridge-bot:matrix.orgbridge-bot <mcormier>If so, that’s probably the problem. I think aragon doesn’t support calling inherited functions from the frontend yet
21:09:52@bridge-bot:matrix.orgbridge-bot <emily>yah that’s definitely gonna be it. I must have put it in the top level contract in my node_modules (face palm) when it was working
21:09:58@bridge-bot:matrix.orgbridge-bot <emily>thanks, @mcormier
21:10:34@bridge-bot:matrix.orgbridge-bot <emily>I'll hold off on updating the npm module for now then and figure out that caching problem later if I need to update
21:18:52@bridge-bot:matrix.orgbridge-bot <emily>yah that’s definitely gonna be it. I must have put it in the top level contract when it was working but deleted the changes unknowingly
18 Sep 2019
01:01:24@bridge-bot:matrix.orgbridge-bot <kin>Hi guys!
01:01:57@bridge-bot:matrix.orgbridge-bot <kin>How I can change a solidity compiler version in Aragon app?
06:09:07@bridge-bot:matrix.orgbridge-bot <aaron> @loic.coenen
06:11:11@bridge-bot:matrix.orgbridge-bot <aaron>@loic.coene looks like you are trying to install allocations app in your dao from the cli. I can’t see the full command you are trying to run
06:13:39@bridge-bot:matrix.orgbridge-bot <aaron>If so you first need to install open enterprises address book app as its a dependency. Then you can re run your last command with the following flags dao install <dao-address> <addressbook-apm-regestry-location> --app-init -args <address-book-address> <vault-address>
06:14:08@bridge-bot:matrix.orgbridge-bot <aaron>If so you first need to install open enterprises address book app as its a dependency. Then you can re run your last command with the following flags dao install <dao-address> <addressbook-apm-regestry-location> --app-init -args <addressbook-address> <vault-address>
12:29:01@bridge-bot:matrix.orgbridge-bot <gabi>@loic.coenen 👆
13:30:18@bridge-bot:matrix.orgbridge-bot <loic.coenen>@aaron @gabi I see! I’m trying to get a dev environement started so I can contribute.
13:31:07@bridge-bot:matrix.orgbridge-bot <loic.coenen>Not familiar with the project architecture yet. I’m talking with emilio @ autark so I should be ok. Thanks!
15:14:36@bridge-bot:matrix.orgbridge-bot <gabi>@dstreppa I looked into the issue you have with cycle dependencies and create this issue to discuss if this is something we would like to support. Invite you to continue the conversation there
15:32:44@bridge-bot:matrix.orgbridge-bot <litvintech>@yalda Hello
When Autark dev meeting will start?
16:02:30@bridge-bot:matrix.orgbridge-bot <dstreppa>Thank you @gabi
19 Sep 2019
17:49:08@bridge-bot:matrix.orgbridge-bot <theophoric>Does anyone recognize this error while publishing → Cannot read property '1' of null ??
17:49:32@bridge-bot:matrix.orgbridge-bot <theophoric>printout

Generate application artifact [failed]
→ Cannot read property '1' of null
✖ Cannot read property '1' of null
❯ TypeError: Cannot read property '1' of null
    at getSignature (/usr/local/lib/node_modules/@aragon/cli/src/helpers/solidity-extractor.js:34:24)
    at getSignature (/usr/local/lib/node_modules/@aragon/cli/src/helpers/solidity-extractor.js💯12)
    at Array.map (<anonymous>)
    at map (/usr/local/lib/node_modules/@aragon/cli/src/helpers/solidity-extractor.js:99:6)
    at tryCatch (/usr/local/lib/node_modules/@aragon/cli/node_modules/regenerator-runtime/runtime.js:45:40)
    at Generator.invoke [as _invoke] (/usr/local/lib/node_modules/@aragon/cli/node_modules/regenerator-runtime/runtime.js:271:22)
    at Generator.prototype.(anonymous function) [as next] (/usr/local/lib/node_modules/@aragon/cli/node_modules/regenerator-runtime/runtime.js:97:21)
    at asyncGeneratorStep (/usr/local/lib/node_modules/@aragon/cli/dist/helpers/solidity-extractor.js:49:103)
    at _next (/usr/local/lib/node_modules/@aragon/cli/dist/helpers/solidity-extractor.js:51:194)

17:50:00@bridge-bot:matrix.orgbridge-bot <theophoric>can build, and run truffle compile / migrate without issue
17:50:22@bridge-bot:matrix.orgbridge-bot <theophoric>or, any suggestions where I should be looking ?
18:03:35@bridge-bot:matrix.orgbridge-bot <theophoric>ah – seems to be an issue with the radspec declarations
21:22:01@bridge-bot:matrix.orgbridge-bot <gabi>@kin the error you got was when the test script from the @aragon/test-helpers use npx to install the ganache-cli package if not available. This cause an error with node-gyp on you local machine. Nevertheless we just include ganache-cli as a dev dependency on the boilerplates in this PR. Could you include it as well and try again?
21:22:19@bridge-bot:matrix.orgbridge-bot <gabi>Let me know how it goes :thumbsup:

There are no newer messages yet.


Back to Room List